ShoreTel Phone Configuration Codes

From a ShoreTel phone, you can ping, view configuration, etc directly from the phone:

For each operation, you press MUTE and then hit the number + #:

PING:
Press MUTE then 7464# (PING)

CLEAR CACHED VALUES:
Press MUTE then 25327# (CLEAR)

RESET PHONE:
Press MUTE then 73738# (RESET)

EDIT CONFIGURATION:
Press MUTE then 73887# (SETUP)

VIEW CONFIGURATION:
Press MUTE then 4636# (INFO)

FACTORY RESET:
Press MUTE then 772667# (RRAMOS), then press 1234 as password and confirm.

Advertisements

21 comments

  1. What phones will this work on? I have the Shoretel 23o phones. I also have a few a other questions for you if that’s ok.

  2. So currently I have acquired a Shoretel phone system. I have a Shoregear 220T1A with the router that was providing digital to analog trunks. Currently I am trying to do a few things. I am wanting to do VLAN’ing with the phones. I have 2 Cisco ASAs – 1 with a security plus license and 1 without. I also have 2 HP Procurve 2626-PWR switches. When I setup VLAN’ing on the Cisco ASAs’ and apply it to switch port, either the phone works or the computer works, not both. I”m not sure how to get both working. Is there a trick for VLAN’ing shoretel phones?

    • There isn’t a trick on the ShoreTel side, but VLAN’ing on an ASA can be difficult, which is why I prefer to do all VLAN-to-VLAN communication on a Layer 3 switch. With a Layer 3 switch, both VLAN’s will be able to talk by default (as long as you have “IP Routing” enabled). You could do this on your HP 2626.

      There are a couple different components to setting up VLAN traffic on the 5505, so I would need a better idea on what you have already done.

  3. Well, i’m trying to get thsi working on the 2626, but not having a lot of luck. I can show my config on the ASA and the HP if you like. But that’s up to you. I’m more than apprciative of your help already. I typically enjoy doing knowledge transfers with the ppl I work with. Let me know.

  4. ProCurve Switch 2626-PWR(config)# sho run

    Running configuration:

    ; J8164A Configuration Editor; Created on release #H.10.83

    hostname “ProCurve Switch 2626-PWR”
    time timezone -6
    time daylight-time-rule Continental-US-and-Canada
    ip default-gateway 10.150.1.1
    sntp server 10.150.1.99
    ip routing
    timesync sntp
    sntp unicast
    snmp-server community “public” Unrestricted
    vlan 1
    name “DEFAULT_VLAN”
    untagged 1-26
    ip address 10.150.1.3 255.255.255.0
    exit
    vlan 1160
    name “production”
    ip address 10.160.1.1 255.255.255.0
    ip helper-address 10.150.1.60
    tagged 1,26
    ip irdp
    exit
    ip route 0.0.0.0 0.0.0.0 10.150.1.1

    ProCurve Switch 2626-PWR(config)#

    • I’m assuming vlan 1160 is your voice vlan. The switchport that your 220T1A is plugged into must be untagged on the voice vlan.

      I’ve never needed ICMP router discovery “ip irdp”, so I’m not sure if that could potentially cause any issues with ShoreTel.

      Since all the voice vlan ports are tagged (I’m assuming you have a single drop per desk, and are plugging in PC’s to the phone), your ShoreTel DHCP scope will need to have Option 156 enabled that tells the phones to tag onto vlan 1160. If you aren’t familiar with this, let me know and I can give you more info.

      To get back to the basics and verify your switch is working correctly, I would untag one port on vlan 1160, plug in a laptop to that port, verify it receives a IP address through DHCP and try to ping something on the 10.150.1.0/24 subnet that doesn’t have its windows firewall enabled. This should work with your config, and once we verify that, we can get into the details.

  5. Let me know if I did it right…i’m still not able to get an IP address.

    Running configuration:

    ; J8164A Configuration Editor; Created on release #H.10.83

    hostname “ProCurve Switch 2626-PWR”
    time timezone -6
    time daylight-time-rule Continental-US-and-Canada
    ip default-gateway 10.150.1.1
    sntp server 10.150.1.99
    ip routing
    timesync sntp
    sntp unicast
    snmp-server community “public” Unrestricted
    vlan 1
    name “DEFAULT_VLAN”
    untagged 2-26
    ip address 10.150.1.3 255.255.255.0
    tagged 1
    exit
    vlan 1160
    name “production”
    ip address 10.160.1.1 255.255.255.0
    ip helper-address 10.150.1.60
    tagged 1
    exit
    ip route 0.0.0.0 0.0.0.0 10.150.1.1

    ProCurve Switch 2626-PWR(vlan-1)#

    • This is how I would configure your switch (with interface descriptions where I would place each device)

      hostname “ProCurve Switch 2626-PWR”
      time timezone -6
      time daylight-time-rule Continental-US-and-Canada
      sntp server 10.150.1.99
      ip routing
      timesync sntp
      sntp unicast
      snmp-server community “public” Unrestricted
      interface 23
      name “ShoreTel 220T1A”
      interface 24
      name “2008R2 DHCP/DNS”
      interface 26
      name “ASA”
      vlan 1
      name “DATA”
      untagged 1-22, 24-26
      ip address 10.150.1.3 255.255.255.0
      exit
      vlan 1160
      name “VOICE”
      untagged 23
      ip address 10.160.1.1 255.255.255.0
      ip helper-address 10.150.1.60
      tagged 1-22
      exit
      ip route 0.0.0.0 0.0.0.0 10.150.1.1

      • Phones can be plugged into ports 1-22. Your DHCP server will need to have option 156 configured on both your data and voice DHCP scope. The option string should be “ftpservers=X.X.X.X,layer2tagging=1,vlanid=1160” where X.X.X.X equals the IP address of your ShoreTel Director server.

  6. So it didn’t seem to work. Windows 2008R2 dhcp isn’t sending out the correct information or i don’t have it setup properly. I put together a Visio of my network. since i can’t upload it here, i’ve placed it here http://imgur.com/A5gzaVu hope this helps. I can clean it up more which I will do later.

    • Hmmm interesting. Are those two different sites connected via VPN? I didn’t realize the 220T1A was not at the same site we were building the switch config for.

      Are the data devices using the HP switch or the ASA as their gateway? If they are using the switch, DHCP (and pings) should have worked. If they are using the ASA, then you would need to add a route to the ASA (route inside 10.160.1.0 255.255.255.0 10.150.1.3). You also need the command “same-security-traffic permit intra-interface” to allow traffic to be routed back down the same interface it came in.

      When testing a non-working configuration, its important to pinpoint the issue. For example, from the DHCP server, can you ping the Voice vlan IP address on the HP switch?

  7. I apologize for not giving you all the information. I was trying to just get the switch working. In fact these aren’t two different offices, I acquired all the equipment from a failed corporation and these are actually at my house and my dad’s house. The end result is to be able to use the Shoretel to call out locally and possibly internationally using pbxes.com. I have inter and intra interface setup on both ASAs. I have the tunnels working already. I will add route inside command to the ASA on my side and test later today.

    • Ok, as you can see implementing VLAN’s can sometimes be a little more involved depending on how your network is setup. For voice traffic to work across your VPN, you will also need to define the voice subnet as “interesting traffic” to be encrypted on both firewalls. Then, you will also need to add the voice subnet into your NONAT policy.

      When implementing a new network/VLAN, I would go through these steps:

      Layer 1: Are all the cables plugged in? If so, what ports?
      Layer 2: Are devices that are not VLAN aware (PC’s, servers) plugged into a port that is “untagged” for their VLAN? Are VLAN aware devices plugged into a port that is either “untagged” or “tagged”? If the port is “tagged”, how does the device know it should tag its traffic?
      Layer 3: Is routing setup so that devices on different networks can talk to each other? If not, follow the path and see where communication stops (ping the device gateway, ping the new network gateway, ping a device on the new network)
      Layer 4+: Verify DHCP works (and ShoreTel DHCP option 156), verify the VPN is encrypting the correct traffic, verify voice works.

      • Ok do for the time being I’m going back to a single vlan and will test without the phones later. The only other thing I am struggling with right now is getting the phones to work with a sip provider. I was going to use pbxes.com. not sure if you have setup sip trunks before. Thoughts?

    • If you are going to run SIP with ShoreTel, I would recommend being on version 13.1+. You will need to have available resources on your ShoreTel switch and allocate SIP trunk resources (and SIP Trunks with Media Proxy if you want features like conferencing, find me). Next, you need to figure out how to get the ITSP SIP trunks to the ShoreTel system. If the ITSP provides the trunks directly to your public IP, you need a SIP SBC to terminate the trunks. If they will establish a VPN tunnel to your firewall (etherspeak does this) then you do not need a SIP SBC.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s