Cisco Router Enable SCP

Enable SCP to easily transfer files to devices (especially if you are behind a NAT):

http://www.ccierants.com/2011/06/great-way-to-copy-files-on-cisco.html

Example: pscp -scp ios-filename.bin admin@routerIPaddress:ios-filename.bin

Advertisements

ASR 1001-X Show Transceiver

On our new ASR I was looking for a command similar to “show interface XXX transceiver”, but that didn’t exist.  Here is the command for the ASR:

To show transceiver hardware details:
#show hw-module interface g0/0/1 transceiver idprom

To show transceiver temp and light levels:
#show hw-module interface g0/0/1 transceiver status

Nexus C9372PX NX-OS Upgrade

Recently upgraded a pair of C9372PX switches with the following commands:

  1. Copy new .bin file over to switch
    copy scp://username@scpserverIPaddress//n9000-dk9.7.0.3.I1.2.bin bootflash:n9000-dk9.7.0.3.I1.2.bin
  2. Show the impact of installing the new version
    show install all impact nxos bootflash:n9000-dk9.7.0.3.I1.2.bin
  3. Install the new version
    install all nxos bootflash:n9000-dk9.7.0.3.I1.2.bin
  4. After you run the install, it will do the impact evaluation again and ask you to confirm installation
  5. Install took less than 5 minutes and then rebooted

The official Cisco install guide can be found HERE

Singlewire Informacast Upgrade

Upgraded from Informacast 9.0.2 to 9.1.1.  Upgrade was very simple and went smoothly following these instructions:

https://www.singlewire.com/help/advanced/cucm/Administer_the_Virtual_Appliance/Virtual_Appliance_Upgrade_Process/Install_New_Software_Package(s).htm

Observations:

  1. If you are doing this upgrade from a Windows client, download Putty PSCP and put it in the same directory as your .deb file you are copying over for step 2.
  2. During step 8, the web portal will be “blank”, but its working behind the scenes.  My install took approximately 5 minutes before showing the install package list

New Cisco ISR4000 Series Routers

I got the chance to install a new Cisco ISR 4431 today, and the best surprise (besides the hugely upgraded throughput) is that the onboard router interfaces now support LACP! Before, you had to resort to getting a switch HWIC module, or just using “mode on” channel-groups.  Since the 4431 has four gig interfaces, you can use LACP for two WAN interfaces, and use LACP for two LAN interfaces using the command “channel-group 1 mode active”.

Show commands:

#show lacp internal

#show lacp neighbor

Cisco vs HP vs Dell CLI – VLAN Configuration

This post continues my series on the differences between these three manufacturers and how they implement L2 and L3 VLANs.

Scenario 1: Create a Layer 2 VLAN

Cisco:
vlan 10

HP:
vlan 10

Dell:
vlan database
vlan 10

Scenario 2: Create a Layer 3 VLAN (that’s routable)

Cisco:
interface vlan 10
ip address 192.168.1.1 255.255.255.0

HP:
vlan 10
ip address 192.168.1.1 255.255.255.0

Dell:
interface vlan 10
ip address 192.168.1.1 255.255.255.0
routing

The biggest difference between all three manufacturers is that HP does not implement a separate VLAN interface for L3 configuration.  Cisco and Dell both require you to go into interface vlan mode before configuring L3 information (IP addressing).  Dell also requires the routing keyword to actually route that VLAN.

**All three manufacturers do require you to input the command IP Routing if you want the switch to route packets**

Cisco vs HP vs Dell CLI – Interface Configuration

After working with all three switch manufacturers in a short period of time, I figured I would do a quick post on how each chooses how to implement VLANs at the interface level.

Scenario 1: Switchport needs to be part of a single native VLAN (VLAN 10)

Cisco:
interface GigabitEthernet1/1
switchport mode access
switchport access vlan 10

HP:
vlan 10
untag 1

Dell:
interface ethernet 1/g1
switchport mode access
switchport access vlan 10

Scenario 2: Switchport needs to be part of a single native VLAN (VLAN 10) and multiple tagged VLANS (VLAN 20,30)

Cisco:
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20,30 (not necessary, but added for security)

HP:
vlan 10
untag 1
vlan 20
tagged 1
vlan 30
tagged 1

Dell:
interface ethernet 1/g1
switchport mode general
switchport general pvid 10
switchport general allowed vlan add 10
switchport general allowed vlan add 20,30 tagged
switchport general allowed vlan remove 1

Obviously the Dell configuration looks a bit convoluted here, but they do require you to manually remove VLAN 1 even though you have specified a different PVID.

Cisco 6500 “Environment Checksum in NVRAM Failed”

Had an issue where an older Cisco 6500 switch was rebooted, and the MSFC would not start correctly and gave the following errors: “environment checksum in nvram failed” and “rommon nvram area is corrupted”.

When trying to log into the the module from CatOS (session 15), the console stated that “module 15 is not installed”.  Tried to to manually boot the MSFC from ROMMON, using this helpful guide: http://www.cisco.com/c/en/us/support/docs/switches/catalyst-6000-series-switches/19284-124.html but kept receiving the “nvram failed” error.  I was convinced it was potentially a hardware issue, but we physically removed the MSFC card, plugged it back in, and the nvram message disappeared and the MSFC module booted!  Good reminder that sometimes the simplest things can resolve a complex issue.

**Note: If you are running a SUP720, there is a field notice for corrupted NVRAM: http://www.cisco.com/c/en/us/support/docs/field-notices/200/fn27595.html

DMVPN Troubleshooting Commands

Some basic IOS IPsec/DMVPN commands to aid with troubleshooting:

show dmvpn detail
show ip nhrp
show ip nhrp multicast

show crypto isakmp sa
show crypto isakmp policy
show crypto ipsec sa

show run | s isakmp
show run | s ipsec
show run | s interface Tunnel

debug crypto isakmp
debug crypto ipsec
(remember to enable terminal monitor if you are remote)